基于RSTP的可靠网络配置

Crq
Crq
Crq
218
文章
0
评论
2021年6月2日18:05:01
评论
441 2228字阅读7分25秒

实验拓扑

公司为提高网络的可靠性,使用了两台高性能交换机作为核心交换机,接入层交换机与核心层交换机互联,形成冗余结构,拓扑如图1所示,

具体要求如下:

(1)为避免交换环路问题,需配置交换机的RSTP功能,加快网络拓扑收敛。要求核心交换机有较高优先级,SW1为根交换机,SW2为备用根交换机,SW1-SW3和SW1-SW4为主链路;

(2)技术部使用VLAN10,网络地址为10.0.1.0/24,PC1和PC2分别接入到SW3和SW4。内部局域网中SW1和SW2为核心交换机,其中将SW1配置为根交换机,SW2为备用根交换机;SW3和SW4作为接入交换机,其中SW1-SW3及SW1-SW4的链路由主链路,SW2-SW4及SW2-SW3的2条链路作为备用链铺路。故在STP配置中需将SW1的优先级设为最高,SW2的优先级为次高,即SW1的优先级为0,SW2的优先级为4096。将连接终端计算机的交换机端口配置为边缘端口,以加速网络的收敛。同时,技术部的计算机划分在VLAN10的网段内,且计算机连接在不同的交换机上,故交换机之间的链路需配置为Trunk模式。

 

基础配置

具体规划表如下:

操作步骤

1.创建VLAN

根据上图VLAN规划表进入四台交换机上配置VLAN。分别进入SW1、SW2、SW3、SW4进行配置。

SW1

system-view
sysname SW1
vlan 10
description Technical

SW2

system-view
sysname SW2
vlan 10
description Technical

SW3

system-view
sysname SW3
vlan 10
description Technical

SW4

system-view
sysname SW4
vlan 10
description Technical

2.将端口划分至相应VLAN

SW1

port-group group-member Ethernet 0/0/1 to Ethernet 0/0/3
port link-type trunk
port trunk allow-pass vlan 10
quit

SW2

port-group group-member Ethernet 0/0/1 to Ethernet 0/0/3
port link-type trunk
port trunk allow-pass vlan 10
quit

SW3

interface Ethernet0/0/10
port link-type access
port default vlan 10
port-group group-member Ethernet 0/0/1 to Ethernet 0/0/2
port link-type trunk
port trunk allow-pass vlan 10
quit

SW4

interface Ethernet0/0/10
port link-type access
port default vlan 10
port-group group-member Ethernet 0/0/1 to Ethernet 0/0/2
port link-type trunk
port trunk allow-pass vlan 10
quit

3.开启STP

SW1-SW4(华为默认开启MSTP改成RSTP即可)

stp mode rstp

 

4.配置RSTP优先级

将SW1配置化为主根交换机,SW2为备份根交换机。

4.1方法 1

SW1的优先级改为0,SW2的优先级改为4096

SW1

stp priority 0

SW2

stp priority 4096

 

4.2 方法 2

首先删除在SW1上所配置的优先级,使用stp root primary命令配置主根交换机。

SW1

undo stp priority
stp root primary

SW2

undo stp priority
stp root secondary

 

 

5.配置边缘端口

SW3

interface Ethernet0/0/10
stp edged-port enable
quit

SW4

interface Ethernet0/0/10
stp edged-port enable
quit

 

 

6.配置各部门计算机的IP地址

 

 

 

7.项目验证

7.1 验证各交换机的VLAN 配置信息

SW1-SW4

display vlan

 

7.2 查看各交换机STP状态

查看各交换机STP状态信息,SW1、SW2使用display stp命令查看stp模式是否正确,SW3、SW4使用display stp brief命令查看备用端口是否处于Discarding状态。

SW1-SW2

display stp

SW3-SW4

dis stp brief

 

 

7.3 测试各部门计算机的互通性

通过Ping命令,测试各部门内部通信息的情况。使用技术部计算机PC1Ping本部门的计算机PC2的IP地址。

ping 10.0.1.2

基于RSTP的可靠网络配置

 

7.4 模拟根端口出现故障的过程

使用display stp brief命令查看SW3的端口角色及状态

display stp brief

模拟接口故障把SW3的EO/0/1端口使用shutdown关闭,同时使用display stp brief命令观察SW2其他端口角色及状态变化。

int e0/0/1
shutdown

 

使用display stp brief观察SW3其他端口的角色及状态变化。

display stp brief

可以发现,当拓扑发生变化时,RSTP根端口快速切换机制使端口状态即从Discarding进入Forwarding状态,缩短收敛的时间,减少了对网络通信的影响。

 

 

 

 

 

weinxin
我的微信
这是我的微信扫一扫
Crq
  • 本文由 发表于 2021年6月2日18:05:01
  • 转载请注明:https://www.cncrq.com/9737.html
IPv6 华为HCIA

IPv6

  IPv6将地址分为了三类:单播、组播、任意播,也就是说我们的IPv6的通信方式也从IPv4的单播、组播、广播发生了一个比较大的改变,那就是没有广播了。 What?没有广播了,那么我们的A...
帧中继 RIP 华为HCIA

帧中继 RIP

实验拓扑   配置命令,自动映射 R1 # sysname R1 # router id 1.1.1.1 # interface Serial1/0/0 link-protocol fr i...
帧中继 OSPF 华为HCIA

帧中继 OSPF

先要了解什么是帧中继 帧中继(frame-ralay)是一种广域网技术,属于分组交换门里的一种;frame-relay是一种二层技术,与具体的物理链路无关。再说说ospf:ospf是一种动态路由协议,...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: