基于VRRP的ISP双出口备份链路配置

Crq
Crq
Crq
218
文章
0
评论
2020年12月4日16:54:12
评论
765 3643字阅读12分8秒

公司原采用ISP-A作为接入服务商,用于内部计算机访问互联网的出口。为提高接入互联网的可靠性,现增加 ISP-B 作为备用接入服务商,当 ISP-A 的接入链路出现故障时,启用ISP-B的接入链路。

 

 

 

实验拓扑

基于VRRP的ISP双出口备份链路配置

操作步骤

(1)配置路由器接口
(2)部署OSPF网络
(3)配置VRRP协议
(4)配置上行接口监视
(5)配置各部门计算机的 IP地址 项目规划如表所示。

实验须知:
1. 所有实验拓扑文件已放在桌面的“实验拓扑”目录中,打开该目录找到相应目录后双击打开拓扑文件即可。
2. 打开实验拓扑后,选中设备,右键选择启动设备。
3. 在每次做完实验后,如需要再次使用已配置的拓扑,请记得另存。

1.基础配置

端口规划表如下:

基于VRRP的ISP双出口备份链路配置

IP地址规划表如下:

基于VRRP的ISP双出口备份链路配置

1.1配置路由器接口

(1) R1的配置
<Huawei>system-view
[Huawei]sysname R1
[R1]interface GigabitEthernet0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.100 255.255.255.0
[R1]interface GigabitEthernet0/0/1
[R1-GigabitEthernet0/0/1] ip address 10.10.10.1 255.255.255.0

基于VRRP的ISP双出口备份链路配置

(2) R2的配置
<Huawei>system-view
[Huawei]sysname R2
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.1.200 255.255.255.0
[R2]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 30.30.30.1 255.255.255.0

基于VRRP的ISP双出口备份链路配置

(3) R3的配置
<Huawei>system-view
[Huawei]sysname R3
[R3]interface GigabitEthernet0/0/1
[R3-GigabitEthernet0/0/1]ip address 10.10.10.2 255.255.255.0
[R3]interface GigabitEthernet0/0/2
[R3-GigabitEthernet0/0/2]ip address 20.20.20.2 255.255.255.0

基于VRRP的ISP双出口备份链路配置

(4) R4的配置
<Huawei>system-view
[Huawei]sysname R4
[R4]interface GigabitEthernet 0/0/1
[R4-GigabitEthernet0/0/1]ip address 40.40.40.2 255.255.255.0
[R4]interface GigabitEthernet 0/0/2
[R4-GigabitEthernet0/0/2] ip address 30.30.30.2 255.255.255.0

基于VRRP的ISP双出口备份链路配置

(5) R5的配置
<Huawei>system-view
[Huawei]sysname R5
[R5]interface GigabitEthernet0/0/0
[R5-GigabitEthernet0/0/0]ip address 100.200.30.2 255.255.255.0
[R5]interface GigabitEthernet0/0/1
[R5-GigabitEthernet0/0/1]ip address 40.40.40.1 255.255.255.0
[R5]interface GigabitEthernet0/0/2
[R5-GigabitEthernet0/0/2]ip address 20.20.20.1 255.255.255.0

基于VRRP的ISP双出口备份链路配置

2.部署OSPF协议

在路由器上配置OSPF协议,使用进程号1,且所有网段均通告进区域0中。

(1) R1的配置
[R1]ospf 1
[R1-ospf-1]area 0
[R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 10.10.10.0 0.0.0.255

基于VRRP的ISP双出口备份链路配置

(2) R2的配置
[R2]ospf 1
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]network 30.30.30.0 0.0.0.255

基于VRRP的ISP双出口备份链路配置

(3) R3的配置
[R3]ospf 1
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]network 10.10.10.0 0.0.0.255
[R3-ospf-1-area-0.0.0.0]network 20.20.20.0 0.0.0.255

基于VRRP的ISP双出口备份链路配置

(4) R4的配置
[R4]ospf 1
[R4-ospf-1]area 0
[R4-ospf-1-area-0.0.0.0]network 30.30.30.0 0.0.0.255
[R4-ospf-1-area-0.0.0.0]network 40.40.40.0 0.0.0.255

基于VRRP的ISP双出口备份链路配置

(5) R5的配置
[R5]ospf 1
[R5-ospf-1]area 0
[R5-ospf-1-area-0.0.0.0]network 20.20.20.0 0.0.0.255
[R5-ospf-1-area-0.0.0.0]network 40.40.40.0 0.0.0.255
[R5-ospf-1-area-0.0.0.0]network 100.200.30.0 0.0.0.255

基于VRRP的ISP双出口备份链路配置

3.配置VRRP协议

在R1、R2上配置VRRP协议,使用vrrp vrid 1 virtual-ip命令创建VRRP备份组,指
定路由器处于同一个VRRP备份组内,VRRP备份组号为1,配置虚拟IP为192.168.1.254。

(1) R1的配置
[R1]interface G0/0/0
[R1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.1.254

基于VRRP的ISP双出口备份链路配置

(2) R2的配置
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.1.254
[R2-GigabitEthernet0/0/0]quit

基于VRRP的ISP双出口备份链路配置

配置R1的优先级为110,R2的优先级保持默认100不变,这样使得R1成为Master,R2为Backup。

[R1-GigabitEthernet0/0/0]vrrp vrid 1 priority 110

基于VRRP的ISP双出口备份链路配置

4.配置上行接口监视

在R1上配置上行接口监视,监视上行接口G0/0/1,当此接口断掉时,裁剪优先级60,
使优先级变为50,小于R2的优先级100。

[R1-GigabitEthernet0/0/0]vrrp vrid 1 track interface GigabitEthernet 0/0/1 reduced 60
[R1-GigabitEthernet0/0/0]quit

基于VRRP的ISP双出口备份链路配置

5.配置各部门计算机的IP地址

PC1 IP配置图如下:

基于VRRP的ISP双出口备份链路配置

服务器 IP配置图如下:

基于VRRP的ISP双出口备份链路配置

6.项目验证

6.1 验证路由器上 OSPF 邻居建立信息

R1的配置

[R1]display ospf peer brief

基于VRRP的ISP双出口备份链路配置

R2的配置

[R2]display ospf peer brief

基于VRRP的ISP双出口备份链路配置

R3的配置

[R3]display ospf peer brief

基于VRRP的ISP双出口备份链路配置

R4的配置

[R4]display ospf peer brief

基于VRRP的ISP双出口备份链路配置

R5的配置

[R5]display ospf peer brief

基于VRRP的ISP双出口备份链路配置

6.2 验证路由器 R1、R2 的 VRRP 信息

R1的配置

[R1]display vrrp

基于VRRP的ISP双出口备份链路配置

R2的配置

[R2]display vrrp

基于VRRP的ISP双出口备份链路配置

可以观察到现在R1的vrrp状态是master,R2是backup。两者都处在vrrp备份组中。

6.3 测试 PC 访问服务器时的数据包转发路径

PC>tracert 100.200.30.1

基于VRRP的ISP双出口备份链路配置

6.4 验证 VRRP 主备切换

将R1的G0/0/1接口关闭
[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]shutdown

基于VRRP的ISP双出口备份链路配置

经过 3s 左右,使用 display vrrp 查看 R1、R2 的 VRRP 信息。
R1的配置
[R1-GigabitEthernet0/0/1]display vrrp

基于VRRP的ISP双出口备份链路配置

R2的配置

[R2]display vrrp

基于VRRP的ISP双出口备份链路配置

可以观察到R1切换成Backup,R2为Master。且R1的vrrp优先级被裁减掉60,变成 50,小于路由器R2的优先级100。测试PC访问服务器时的数据包转发路径

PC>tracert 100.200.30.1

基于VRRP的ISP双出口备份链路配置

发现数据包发送路径已经切换到 R2。

7. 保存设备配置

使用Ctrl+Z的组合键退出到用户视图后,再进行保存。
<R1>save

基于VRRP的ISP双出口备份链路配置

<R2>save

基于VRRP的ISP双出口备份链路配置

<R3>save

基于VRRP的ISP双出口备份链路配置

<R4>save

基于VRRP的ISP双出口备份链路配置

<R5>save

基于VRRP的ISP双出口备份链路配置

 

下载信息 资源名称:拓扑图下载 应用平台:eNSP
下载地址:发表评论并刷新可见
weinxin
我的微信
这是我的微信扫一扫
Crq
  • 本文由 发表于 2020年12月4日16:54:12
  • 转载请注明:https://www.cncrq.com/8897.html
IPv6 华为HCIA

IPv6

  IPv6将地址分为了三类:单播、组播、任意播,也就是说我们的IPv6的通信方式也从IPv4的单播、组播、广播发生了一个比较大的改变,那就是没有广播了。 What?没有广播了,那么我们的A...
帧中继 RIP 华为HCIA

帧中继 RIP

实验拓扑   配置命令,自动映射 R1 # sysname R1 # router id 1.1.1.1 # interface Serial1/0/0 link-protocol fr i...
帧中继 OSPF 华为HCIA

帧中继 OSPF

先要了解什么是帧中继 帧中继(frame-ralay)是一种广域网技术,属于分组交换门里的一种;frame-relay是一种二层技术,与具体的物理链路无关。再说说ospf:ospf是一种动态路由协议,...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: