基于静态路由的公司与分部互联

Crq
Crq
Crq
218
文章
0
评论
2021年5月17日19:35:36
评论
727 1690字阅读5分38秒

公司有北京总部、广州分部和上海分部 3 个办公地点,各分部与总部之间使用路由器互联。北京、上海、广州的路由器分别为 R1、R2、R3,路由器需配置静态路由,使所有计算机能够互相访问

实验拓扑

基于静态路由的公司与分部互联

 

操作步骤

北京总部使用 192.168.1.0 网段,上海分部使用 172.16.1.0 网段,广州分部使用10.10.10.0 网段,R1 与 R2 之间为 20.20.20.0 网段,R1 与R3 之间为 30.30.30.0 网段,R2
与 R3 之间为 40.40.40.0 网段,所有网段均使用 24 位子网掩码。路由器配置相应的静态路由,使所有计算机均能互访。
配置步骤如下:
(1)配置路由器接口
(2)配置静态路由
(3)配置各计算机的 IP 地址 具体规划如下表:

基于静态路由的公司与分部互联

基于静态路由的公司与分部互联

配置路由器接口

system-view 
sysname R1 
interface GigabitEthernet  0/0/0
ip address 192.168.1.10 255.255.255.0 
interface GigabitEthernet  0/0/1
ip address 20.20.20.1 255.255.255.0 
interface GigabitEthernet  0/0/2 
ip address 30.30.30.1 255.255.255.0 
quit

基于静态路由的公司与分部互联

 

 

R2 的配置

system-view 
sysname R2 
interface GigabitEthernet 0/0/0 
ip address 172.16.1.10 255.255.255.0 
interface GigabitEthernet 0/0/1 
ip address 20.20.20.10 255.255.255.0
interface GigabitEthernet 0/0/2 
ip address 40.40.40.10 255.255.255.0
quit

基于静态路由的公司与分部互联

 

 

R3 的配置

system-view 
sysname R3 
interface GigabitEthernet 0/0/0 
ip address 10.10.10.10 255.255.255.0
interface GigabitEthernet 0/0/1 
ip address 40.40.40.1 255.255.255.0 
interface GigabitEthernet 0/0/2 
ip address 30.30.30.10 255.255.255.0 
quit

基于静态路由的公司与分部互联

 

配置静态路由

在R1 上配置目的网段为主机PC2 所在网段的静态路由,即目的 IP 地址为 172.16.1.0, 掩码 255.255.255.0 即 24 位。对于 R1 而言,要发送数据到主机 PC2,则必须先发送给 R2, 所以 R2 即为 R1 的下一跳路由,R2 与 R1 所在的直连链路上的物理接口的 IP 地址即为下一跳 IP 地址,即 20.20.20.10。

ip route-static 172.16.1.0 24 20.20.20.10 
ip route-static 10.10.10.0 24 30.30.30.10

基于静态路由的公司与分部互联

 

 

采取同样方式在R2 上配置目的网段为PC1、PC3 所在网段的静态路由

ip route-static 192.168.1.0 24 20.20.20.1 
ip route-static 10.10.10.0 24 40.40.40.1 

基于静态路由的公司与分部互联

 

 

采取同样方式在R3 上配置目的网段为PC1、PC2 所在网段的静态路由

ip route-static 192.168.1.0 24 30.30.30.1
ip route-static 172.16.1.0 24 40.40.40.10

基于静态路由的公司与分部互联

 

 

配置各计算机的 IP 地址

基于静态路由的公司与分部互联

基于静态路由的公司与分部互联

基于静态路由的公司与分部互联

验证现象

验证路由器上路由表的配置信息

R1 的配置

display ip routing-table

基于静态路由的公司与分部互联

 

 

R2 的配置

display ip routing-table

基于静态路由的公司与分部互联

 

 

R3 的配置

display ip routing-table

基于静态路由的公司与分部互联

 

 

通过 Ping 命令,测试各计算机内部通信息的情况。
使用 PC1 Ping PC2 的计算机:

PC>ping 172.16.1.1

基于静态路由的公司与分部互联

 

使用 PC1 Ping PC3 的计算机:

PC>ping 10.10.10.1

基于静态路由的公司与分部互联

weinxin
我的微信
这是我的微信扫一扫
Crq
  • 本文由 发表于 2021年5月17日19:35:36
  • 转载请注明:https://www.cncrq.com/9480.html
IPv6 华为HCIA

IPv6

  IPv6将地址分为了三类:单播、组播、任意播,也就是说我们的IPv6的通信方式也从IPv4的单播、组播、广播发生了一个比较大的改变,那就是没有广播了。 What?没有广播了,那么我们的A...
帧中继 RIP 华为HCIA

帧中继 RIP

实验拓扑   配置命令,自动映射 R1 # sysname R1 # router id 1.1.1.1 # interface Serial1/0/0 link-protocol fr i...
帧中继 OSPF 华为HCIA

帧中继 OSPF

先要了解什么是帧中继 帧中继(frame-ralay)是一种广域网技术,属于分组交换门里的一种;frame-relay是一种二层技术,与具体的物理链路无关。再说说ospf:ospf是一种动态路由协议,...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: