PPPoE认证

Crq
Crq
Crq
218
文章
0
评论
2021年6月10日21:50:16
评论
608 1725字阅读5分45秒

试验拓扑

公司向ISP服务提供商申请了一条专用线路用于互联网接入,线路采用PPPoE接入方式。现需配置出口路由器,使内网使用可以通过共享出口路由器访问互联网。项目拓扑如图所示。

PPPoE认证

 

操作步骤

(1)配置PPPoE认证服务器

(2)配置PPPoE客户端

(3)配置各计算机的IP地址具体规划如下表

1. 基本配置IP地址规划表如下:

 

PPPoE认证

端口规划表如下:

PPPoE认证

 

2. 配置 PPPoE 服务器

(1)修改ISP路由器的设备名,并配置Loopback1接口的IP;

system-view
sysname ISP
interface LoopBack1
ip address 10.10.10.1 255.255.255.0

(2)配置 PPPoE 地址池,通过使用全局地址池给对端分配地址,实现 PPPoE Server 为 PPPoE Client动态分配IP地址。

ip pool pppoe 
gateway-list 20.20.20.1 
network 20.20.20.0 mask 255.255.255.0

(3)配置PPPoE认证用户,实现PPPoE Server对用户主机的认证。

aaa 
local-user r1 password cipher 123456 
local-user r1 privilege level 0 
local-user r1 service-type ppp

(4)配置虚拟接口模板VT,本端PPPoE协议对对端设备的认证方式为CHAP。

interface Virtual-Template 1 
ppp authentication-mode chap 
remote address pool pppoe 
ip address 20.20.20.1 255.255.255.0

(5)启用PPPoE Server功能,在以太网接口G0/0/0上启用PPPoE Server功能。

interface GigabitEthernet 0/0/0 
pppoe-server bind Virtual-Template 1

3. 配置 PPPoE 客户端

(1)修改R1路由器的设备名,并配置G0/0/1接口的IP作为内网用户的网关;

system-view
sysname R1
int G0/0/1
ip address 192.168.10.254 255.255.255.0

(2)配置Dialer接口。

interface Dialer0
ppp chap user r1
ppp chap password cipher 123456
tcp adjust-mss 1200
ip address ppp-negotiate
dialer user isp
dialer bundle 1

(3)建立 PPPoE 会话

interface GigabitEthernet0/0/0 
pppoe-client dial-bundle-number 1

(4)配置 NAT 转换,配置局域网用户通过NAT转换将私网地址转换为公网地址,进行拨号上网。

acl number 3000
rule 5 permit ip source 192.168.10.0 0.0.0.255
quit
interface Dialer0
nat outbound 3000

(5)配置到 PPPoE Server 的静态路由

ip route-static 0.0.0.0 0 dialer 0

4. 配置各计算机的 IP 地址机的 IP 地址

PC1 IP配置图:
PPPoE认证

PC2 IP配置图:PPPoE认证

 

PC3 IP配置图:PPPoE认证

 

5. 项目验证

5.1 查看 PPPoE server 会话的状态和配置信息

(1) 在ISP上使用display pppoe-server session all命令查看pppoe会话信息;

display pppoe-server session all

可以观察到,会话状态正常(状态为UP表示正常)、配置正确(和之前的数据规划和组网一致)。

 

5.2 查看 PPPoE client 会话状态和配置信息(1)在R1上使用display pppoe-client session summary命令查看pppoe会话信息;

display pppoe-client session summary dial-bundle-number 1

可以观察到,会话状态正常(状态为UP表示正常)。

 

5.3 测试各计算机的互通性使用PC1计算机Ping ISP路由器LoopBack:

ping 10.10.10.1

 

 

weinxin
我的微信
这是我的微信扫一扫
Crq
  • 本文由 发表于 2021年6月10日21:50:16
  • 转载请注明:https://www.cncrq.com/9889.html
IPv6 华为HCIA

IPv6

  IPv6将地址分为了三类:单播、组播、任意播,也就是说我们的IPv6的通信方式也从IPv4的单播、组播、广播发生了一个比较大的改变,那就是没有广播了。 What?没有广播了,那么我们的A...
帧中继 RIP 华为HCIA

帧中继 RIP

实验拓扑   配置命令,自动映射 R1 # sysname R1 # router id 1.1.1.1 # interface Serial1/0/0 link-protocol fr i...
帧中继 OSPF 华为HCIA

帧中继 OSPF

先要了解什么是帧中继 帧中继(frame-ralay)是一种广域网技术,属于分组交换门里的一种;frame-relay是一种二层技术,与具体的物理链路无关。再说说ospf:ospf是一种动态路由协议,...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: