基于默认路由及浮动路由的公司与分部互联

Crq
Crq
Crq
218
文章
0
评论
2020年12月29日11:27:59
评论
790 1515字阅读5分3秒

公司有北京总部和上海分部 2 个办公地点,分部与总部之间使用路由器互联。北京、上海的路由器分别为 R1、R2,路由器需配置默认路由和浮动路由,提高链路的可用性, 使所有计算机能够互相访问。

实验拓扑

基于默认路由及浮动路由的公司与分部互联

 

1.基本配置

1.1 IP地址规划

北京总部使用 192.168.1.0 网段,上海分部使用 172.16.1.0 网段,R1与R2 之间为 10.10.10.0 网段,R1与R2 之间为 20.20.20.0 网段,所有网段均使用 24 位子网掩码。路由器配置相应的默认路由及浮动路由,在配置浮动路由优先级时,配置 10.10.10.0 网段为主链路,20.20.20.0 网段为备份链路,最终实现公司计算机与分部计算机可以互通。
具体配置步骤如下:
1、 配置各路由器及计算机的接口
2、 配置 R1、R2 的静态路由
3、 配置 R1、R2 的浮动路由具体规划如下表:

基于默认路由及浮动路由的公司与分部互联

基于默认路由及浮动路由的公司与分部互联

1.2配置路由器接口

R1 的配置

system-view
sysname R1
interface GigabitEthernet 0/0/0
ip address 192.168.1.254 255.255.255.0
interface GigabitEthernet 0/0/1
ip address 10.10.10.1 255.255.255.0
interface GigabitEthernet 0/0/2
ip address 20.20.20.1 255.255.255.0
quit

基于默认路由及浮动路由的公司与分部互联

R2 的配置

system-view
sysname R2
interface GigabitEthernet 0/0/0
ip address 172.16.1.254 255.255.255.0
interface GigabitEthernet 0/0/1
ip address 10.10.10.10 255.255.255.0
interface GigabitEthernet 0/0/2
ip address 20.20.20.10 255.255.255.0
quit

基于默认路由及浮动路由的公司与分部互联

1.3配置 R1R2 的静态路由

R1 的配置

ip route-static 0.0.0.0 0.0.0.0 10.10.10.10

基于默认路由及浮动路由的公司与分部互联

R2 的配置

ip route-static 0.0.0.0 0.0.0.0 10.10.10.1

基于默认路由及浮动路由的公司与分部互联

1.4配置 R1R2 的浮动路由

R1 的配置

ip route-static 0.0.0.0 0.0.0.0 20.20.20.10 preference 100

基于默认路由及浮动路由的公司与分部互联

R2 的配置

ip route-static 0.0.0.0 0.0.0.0 20.20.20.1 preference 100

基于默认路由及浮动路由的公司与分部互联

1.5配置各计算机的 IP 地址

基于默认路由及浮动路由的公司与分部互联

基于默认路由及浮动路由的公司与分部互联

  1. 验证现象

2.1验证路由表的配置信息

R1 路由表配置信息

display ip routing-table

基于默认路由及浮动路由的公司与分部互联

2.2测试各计算机的互通性

通过 Ping 命令,测试主机 PC1 与 PC2 间的通信。使用 PC1 Ping PC2 的计算机:

ping 172.16.1.1

基于默认路由及浮动路由的公司与分部互联

通信正常,再使用 tracert 命令查看此时PC1 与 PC2 通信间所经过的网关。

tracert 172.16.1.1

基于默认路由及浮动路由的公司与分部互联

可以看出,PC 间相互通信使用主链路。

2.3测试计算机通信使用备用链路

将关掉R1的G0/0/1端口,通过 Ping 命令,测试主机 PC1 与 PC2 间的通信。

int g0/0/1
shutdown

基于默认路由及浮动路由的公司与分部互联

 

使用 PC1 Ping PC2 的IP地址。

ping 172.16.1.1

基于默认路由及浮动路由的公司与分部互联

通信正常,再使用 tracert 命令查看此时PC1 与 PC2 通信间所经过的网关。

tracert 172.16.1.1

基于默认路由及浮动路由的公司与分部互联

可以看出,PC 间相互通信使用备份链路。

恢复R1的G0/0/1接口。

int g0/0/1
undo shutdown
quit

基于默认路由及浮动路由的公司与分部互联

weinxin
我的微信
这是我的微信扫一扫
Crq
  • 本文由 发表于 2020年12月29日11:27:59
  • 转载请注明:https://www.cncrq.com/8965.html
IPv6 华为HCIA

IPv6

  IPv6将地址分为了三类:单播、组播、任意播,也就是说我们的IPv6的通信方式也从IPv4的单播、组播、广播发生了一个比较大的改变,那就是没有广播了。 What?没有广播了,那么我们的A...
帧中继 RIP 华为HCIA

帧中继 RIP

实验拓扑   配置命令,自动映射 R1 # sysname R1 # router id 1.1.1.1 # interface Serial1/0/0 link-protocol fr i...
帧中继 OSPF 华为HCIA

帧中继 OSPF

先要了解什么是帧中继 帧中继(frame-ralay)是一种广域网技术,属于分组交换门里的一种;frame-relay是一种二层技术,与具体的物理链路无关。再说说ospf:ospf是一种动态路由协议,...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: