基于单区域 OSPF 协议互联的公司网络搭建

Crq
Crq
Crq
218
文章
0
评论
2020年11月26日10:33:58
评论
1,0602 2039字阅读6分47秒

公司有北京总部、广州分部和上海分部 3 个办公地点,各分部与总部之间使用路由器互联。公司要求通过配置单区域 OSPF 动态路由,实现公司之间能够互相访问。

 

 

实验拓扑

基于单区域 OSPF 协议互联的公司网络搭建

操作步骤

1. 打开实验拓扑后,选中设备,右键选择启动设备。
2. 在每次做完实验后,如需要再次使用已配置的拓扑,请记得另存。

 

1.基本配置

1.1基础配置

北京总部使用 192.168.1.0 网段,上海分部使用 172.16.1.0 网段,广州分部使用10.10.10.0 网段,R1 与 R2 之间为 20.20.20.0 网段,R1 与R3 之间为 30.30.30.0 网段,R2
与 R3 之间为 40.40.40.0 网段,所有网段均使用 24 位子网掩码。路由器需配置单区域 OSPF 动态路由,使所有计算机均能互访。
配置步骤如下:
(1)配置路由器接口
(2)部署单区域 OSPF 网络
(3)配置各计算机的 IP 地址与网关 业务规划如下表:

基于单区域 OSPF 协议互联的公司网络搭建

基于单区域 OSPF 协议互联的公司网络搭建

1.2配置路由器接口

基于单区域 OSPF 协议互联的公司网络搭建

system-view 
sysname R1 
interface GigabitEthernet 0/0/0 
ip address 192.168.1.1 255.255.255.0 
interface GigabitEthernet 0/0/1 
ip address 20.20.20.1 255.255.255.0 
interface GigabitEthernet 0/0/2 
ip address 30.30.30.1 255.255.255.0 
quit

基于单区域 OSPF 协议互联的公司网络搭建

system-view
sysname R2 
interface GigabitEthernet 0/0/0 
ip address 172.16.1.2 255.255.255.0
interface GigabitEthernet 0/0/1 
ip address 20.20.20.2 255.255.255.0 
interface GigabitEthernet 0/0/2 
ip address 40.40.40.2 255.255.255.0 
quit

基于单区域 OSPF 协议互联的公司网络搭建

system-view 
sysname R3 
interface GigabitEthernet 0/0/0 
ip address 10.10.10.3 255.255.255.0 
interface GigabitEthernet 0/0/1 
ip address 40.40.40.3 255.255.255.0
interface GigabitEthernet 0/0/2 
ip address 30.30.30.3 255.255.255.0 
quit

1.3部署单区域 OSPF 网络

首先创建并运行 OSPF,接着创建区域并进入 OPSF 区域视图,指定运行 OSPF 协议的接口和接口所属的区域。

基于单区域 OSPF 协议互联的公司网络搭建

ospf 1
area 0
network 192.168.1.0 0.0.0.255
network 20.20.20.0 0.0.0.255
network 30.30.30.0 0.0.0.255

基于单区域 OSPF 协议互联的公司网络搭建

ospf 1
area 0
Network 172.16.1.0 0.0.0.255
network 20.20.20.0 0.0.0.255
network 40.40.40.0 0.0.0.255

基于单区域 OSPF 协议互联的公司网络搭建

ospf 1
area 0
network 10.10.10.0 0.0.0.255
network 40.40.40.0 0.0.0.255
network 30.30.30.0 0.0.0.255

1.4配置各计算机的 IP 地址

 配置PC1的IP

基于单区域 OSPF 协议互联的公司网络搭建

 配置PC2的IP

基于单区域 OSPF 协议互联的公司网络搭建

 配置PC3的IP

基于单区域 OSPF 协议互联的公司网络搭建

2.1验证 OSPF 接口通告

基于单区域 OSPF 协议互联的公司网络搭建

display ospf interface

基于单区域 OSPF 协议互联的公司网络搭建

display ospf interface

基于单区域 OSPF 协议互联的公司网络搭建

display ospf interface

“Type”为以太网默认的广播网类型;“State”为该接口当前的状态,显示为 DR 状态。

2.2查看 OSPF 邻居状态

基于单区域 OSPF 协议互联的公司网络搭建

display ospf peer

通过这条命令,Router-ID 可以查看邻居的路由器标识;通过 Address 可以查看邻居的OSPF 接口 IP 地址;通过 State 可以查看目前与该路由器的 OSPF 的邻居状态;通过 Priority 可以查看当前该邻居 OSPF 接口的 DR 优先级。

2.3查看 OSPF 路由表

基于单区域 OSPF 协议互联的公司网络搭建

display ip routing-table protocol ospf

通过此路由表可以观察到,“Destination/Mask”标识了目的网段的前缀及掩码, “Proto”标识了此路由信息是通过 OSPF 协议获取的,“Pre”标识了路由优先级,“Cost”标识了开销值,“NextHop”标识了下一跳地址,“Interface”标识了此前缀的出接口。

2.4测试各部门计算机的互通性

基于单区域 OSPF 协议互联的公司网络搭建

ping 172.16.1.10

基于单区域 OSPF 协议互联的公司网络搭建

ping 10.10.10.10

可以看出,各计算机能相互通信。

3.1保存配置

使用Ctrl+Z的组合键退出到用户视图后,再进行保存。
请注意在输入save后,请根据提示输入'y'并按回车键进行确认

分别保存R1,R2,R3的配置

基于单区域 OSPF 协议互联的公司网络搭建

save

基于单区域 OSPF 协议互联的公司网络搭建

save

基于单区域 OSPF 协议互联的公司网络搭建

save
下载信息
网盘密码:发表评论并刷新可见
下载地址
weinxin
我的微信
这是我的微信扫一扫
Crq
  • 本文由 发表于 2020年11月26日10:33:58
  • 转载请注明:https://www.cncrq.com/8838.html
IPv6 华为HCIA

IPv6

  IPv6将地址分为了三类:单播、组播、任意播,也就是说我们的IPv6的通信方式也从IPv4的单播、组播、广播发生了一个比较大的改变,那就是没有广播了。 What?没有广播了,那么我们的A...
帧中继 RIP 华为HCIA

帧中继 RIP

实验拓扑   配置命令,自动映射 R1 # sysname R1 # router id 1.1.1.1 # interface Serial1/0/0 link-protocol fr i...
帧中继 OSPF 华为HCIA

帧中继 OSPF

先要了解什么是帧中继 帧中继(frame-ralay)是一种广域网技术,属于分组交换门里的一种;frame-relay是一种二层技术,与具体的物理链路无关。再说说ospf:ospf是一种动态路由协议,...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: